Ciscoルータで学ぶネットワーク > スタティックルーティング(構築例2)
当サイト概要CCNA・CCENT・資格書籍学習環境の準備リンクについてリンクの申込お問い合せプライバシーポリシー
◆スタティックルーティング(構築例2)

スタティックルーティング(構築例2)


 「スタティックルーティング(構築例1)」で構築したネットワークは、ルートの向きが一方行で、ルートの向きについて考える必要がありませんでした。

今度は、下の図のネットワークをスタティックルートで、ネットワークを構築してみます。

 静的ルートの設定では、宛先ネットワークへ到達するために、隣のどのルータのどのインタフェースにパケットを渡してやるのか指定して行きます。



 各ルータの、ルートの向きは、下のようになります。Router_Bのルートの向きに注目して下さい。宛先ネットワークによって、ネクストホップの指定が変わってきます。

Router_A Router_B Router_C
172.16.3.0/24 → ← 172.16.1.0/24   ← 172.16.1.0/24
172.16.4.0/24 →   172.16.4.0/24 → ← 172.16.2.0/24

 ルートの設定では、宛先ネットワークへ到達するために、隣のルータのどのインタフェースにパケットを渡してやるのか指定して行きます。

※自分(ルータ)のどのインタフェースからパケットを送信すればよいのかを指示することもできます。


Rotuer_Bのルートの設定は、以下のようになります。

Router_B(config)#ip route 172.16.1.0 255.255.255.0 172.16.2.1
Router_B(config)#ip route 172.16.4.0 255.255.255.0 172.16.3.2

 スタティックルート設定では、ルートの向きに気をつけて下さい。ルーティングテーブルに間違った経路情報があると、正しく宛先にパケットを配送できなくなります。

●Router_Aのコンフィグ
!
hostname Router_A
!
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 bandwidth 64
 ip address 172.16.2.1 255.255.255.0
 clock rate 64000
!
ip classless
ip route 172.16.3.0 255.255.255.0 172.16.2.2 
ip route 172.16.4.0 255.255.255.0 172.16.2.2 
!

●Router_Bのコンフィグ
!
hostname Router_B
!
interface Serial0/0/0
 bandwidth 64
 ip address 172.16.2.2 255.255.255.0
!
interface Serial0/0/1
 bandwidth 64
 ip address 172.16.3.1 255.255.255.0
 clock rate 64000
!
ip classless
ip route 172.16.1.0 255.255.255.0 172.16.2.1 
ip route 172.16.4.0 255.255.255.0 172.16.3.2 
!

●Router_Cのコンフィグ
!
hostname Router_C
!
interface FastEthernet0/0
 ip address 172.16.4.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 bandwidth 64
 ip address 172.16.3.2 255.255.255.0
!
ip classless
ip route 172.16.1.0 255.255.255.0 172.16.3.1 
ip route 172.16.2.0 255.255.255.0 172.16.3.1 
!


◆Menu
◆スポンサードリンク
◆Amazon

Copyright(c)2014〜 Ciscoルータで学ぶネットワーク All rights reserved.