Ciscoルータで学ぶネットワーク > スタティックルーティング(構築例1)
当サイト概要CCNA・CCENT・資格書籍学習環境の準備リンクについてリンクの申込お問い合せプライバシーポリシー
◆スタティックルーティング(構築例1)

スタティックルーティング(構築例1)


ルーティングテーブルの作成方法は、2つあります。

●スタティックルーティング(静的ルーティング)
●ダイナミックルーティング(動的ルーティング)


この2つのアプローチがあります。

 ここでは、スタティックルートの設定を行ってゆきます。

 スタティックルーティングとは、管理者がルータにネットワークのルート情報を手動で教えてあげる方法です。

 この方法は、宛先へのルートを固定する場合や、宛先へのルートが1つに限定される時に使います。


 スタティックルーティングとは、管理者がルータにネットワークのルート情報を手動で教えてあげる方法です。この方法は、宛先へのルートを固定する場合や、宛先へのルートが1つに限定される時に使います。

 スタティックルートの設定は、ルータにネットワーク上に存在する全ての宛先ネットワークの情報を教えてあげなくては、なりません。宛先ネットワーク情報が不足する場合、教えてあげていない、宛先へのルーティングが行えなくなります。

 ルータに教えてあげたルート情報は、ルーティングテーブルに追加されます。ルータは、パケットを受信すると、このルーティングテーブルを参照して、隣のルータ(送信インタフェース)にパケットを配送します。ルーティングテーブルに、宛先ネットワークへのエントリーが見つからない場合、配達不能になるので、パケットを破棄します。

 スタティックルーティングの欠点は、ネットワークの動的な変化に対応できないことです。ある経路に障害が発生した場合、迂回することができません。つまり、ネットワークの変更がある度に、管理者がルータを設定し直さなければなりません。

 長所は、ダイナミックルーティングのようにルーティング情報の交換が行われないので、帯域幅を圧迫しないので帯域幅の節約になります。また、ルート情報が、ルーティングアップデートとしてネットワーク上を流れることがないので、セキュリティ面において高い特徴があります。

それでは、下の図のように、シンプルなネットワークを構築してみましょう!


 ルータは、直接接続しているネットワークに関しては、特にルーティングに関する設定を行わなくても知っています。ただし、インタフェースには、IPアドレスを設定する必要があります。

スタティックルーティングの設定は、ルータが知らないネットワークを設定してゆきます。

それでは,Router_AとRouter_Bが知らないネットワークとは、どのネットワークになるのでしょうか?

Router_Aは、直接接続していない、「192.168.3.0」ネットワーク
Router_Bは、直接接続していない、「192.168.1.0」ネットワーク

を知らないことになります。

ここで、気をつけて欲しいのは、通信は、行きと戻りがあるということです。

 例えば、PC_AからPC_Bに通信する場合、Router_Aだけが、「192.168.3.0」を含む全てのルートを持っていて、Router_Bが「192.168.1.0」のルートを知らなかったとします。

宛先のPC_Bには、パケットが届けることができますが、戻りのパケットが、送信元であるPC_Aに届かないことになります。

 PC_AからPC_Bに送られるパケットの宛先ネットワークアドレスは、「192.168.3.0」になりますが、PC_Bに到着後の戻りのパケットの宛先ネットワークアドレスは、「192.168.1.0」になります。このネットワークのルートをRouter_Bが知らないと、戻りのパケットが破棄されてしまうのです。

つまり、

Router_Aには、「192.168.3.0」ネットワークへのルート
Router_Bには、「192.168.1.0」ネットワークへのルート

を教えてあげなければなりません。

◆スタティックルートの設定

スタティックルートの設定は、次のコマンドを使って設定します。

Router(config)#ip route <ネットワーク> <サブネットマスク> <ネクストホップ|インタフェース>

Router_Aに、「192.168.3.0」ネットワークへのルートを教えてあげるには、

Router_A(config)#ip route 192.168.3.1 255.255.255.0 192.168.2.1

 ネクストホップに、隣のルータのインタフェースのIPアドレスを指定します。隣のルータのIPアドレスと言っても、何でもいいわけではありません。Router_Aは、「192.168.3.0」ネットワークへパケットを送るために自分のS0インタフェースから送出するようになるので、その接続先であるRouter_BのS0インタフェースのIPアドレスを指定しなければなりません。

 ここでは、ネクストホップの指定の仕方として隣のルータのIPアドレスを指定しましたが、送信インタフェースを指定してもかまいません。

Router(config)#ip route 192.168.3.1 255.255.255.0 s0

と指定しても同様にルーティングできます。

ただし、インタフェースを指定できるのは、今回のように、ポイントツーポイント接続の場合のみです。

Router_A、Router_Bの設定は、以下のようになります。出力結果は、機種、IOSのバージョンで若干異なる場合があります。

●Router_Aのコンフィグ
!
hostname Router_A
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 bandwidth 64
 ip address 192.168.2.1 255.255.255.0
 clock rate 64000
!
ip classless
ip route 192.168.3.0 255.255.255.0 192.168.2.2 
!

●Router_Bのコンフィグ
!
hostname Router_B
!
interface FastEthernet0/0
 ip address 192.168.3.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 bandwidth 64
 ip address 192.168.2.2 255.255.255.0
!
ip classless
ip route 192.168.3.0 255.255.255.0 192.168.2.1 
!

設定が、完了したら、PC_AからPC_BへPingをしてみましょう!

Pingが成功するはずです。


ルーティングテーブルを確認する


それぞれのルータでルーティングテーブルを確認してみましょう!

Router#show ip route

●Router_Aの「show ip route」の出力
Router_A#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, FastEthernet0/0
C    192.168.2.0/24 is directly connected, Serial0/0/0
S    192.168.3.0/24 [1/0] via 192.168.2.2

●Router_Bの「show ip route」の出力
Router_B#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

S    192.168.1.0/24 [1/0] via 192.168.2.1
C    192.168.2.0/24 is directly connected, Serial0/0/0
C    192.168.3.0/24 is directly connected, FastEthernet0/0

上の出力で、黄色く網掛けしている部分に注目して下さい。

Router_Aでは、

S 192.168.3.0/24 [1/0] via 192.168.2.2

Router_Bでは、

S 192.168.1.0/24 [1/0] via 192.168.2.1

 「S」というマークが付いています。これは、「static」と言う意味です。その経路がスタティックルートであることを示しています。これらのルートは、インタフェースがダウンすると消えてなくなってしまいます。

 インタフェースがダウンした場合、ルートが消えないようにするには、「parmanent」オプションを指定すると、消えなくなりますが、ここでは、割愛します。
◆Menu
◆スポンサードリンク
◆Amazon

Copyright(c)2014〜 Ciscoルータで学ぶネットワーク All rights reserved.