Ciscoルータで学ぶネットワーク > デフォルトルートとip classless
当サイト概要CCNA・CCENT・資格書籍学習環境の準備リンクについてリンクの申込お問い合せプライバシーポリシー
◆デフォルトルートとip classless

デフォルトルートとip classless


 「ip classless」コマンドを設定すると最善のスーパーネットルートにフォワードすることができるようになります。デフォルトルートを使用する際は、このコマンドを使います。

 「ip classless」コマンドを設定すると、未知のネットワークを宛先とするパケットをデフォルトルートに転送することができるようになります。「ip classless」コマンドの設定がないと、たとえ、デフォルトルートが存在したとしても、そのパケットは、廃棄されてしまいます。

 Cisco IOS 11.3以降を搭載しているCiscoルータでは、デフォルトで、このコマンドが、設定されています。Cisco IOS 11.3より古いIOSを使用している場合は、このコマンドを設定しないとクラスレスルーティングやデフォルトルートを使うことができません。

それでは、下の図のネットワークを構築して、「ip classless」を設定しないと、デフォルトルートが使われないかを検証して行きます。


各ルータの、ルートの向きは、下のようになります。

 Router_A、Router_Cのルートの向きにに注目して下さい。全てのルートが一方通行です。上のネットワークは、小さなネットワークでルートの数が少なくて済みますが、規模が大きくなってくると、スタティックルートのエントリーが増えてきます。その際、全てのネットワークのエントリーを定義していくのは、とても面倒です。

そんな時に役立つのがデフォルトルートです!

Router_A Router_B Router_C
172.16.3.0/24 → ← 172.16.1.0/24   ← 172.16.1.0/24
172.16.4.0/24 →   172.16.4.0/24 → ← 172.16.2.0/24


 デフォルトルートは、上図のように、インターネットに接続するルータで設定するケースが多いです。インターネット上の経路は、非常にたくさんあり、数十万経路とも言われています。

 そのインターネット上の全てのルートを把握するのは、事実上、困難ですし、絶えず変化するネットワークにあわせてルータのルーティングテーブルをメンテナンスするのは神業です。

 また、インターネット上の全てのルートをルータのルーティングテーブルに載せるだけのルータのメモリもCPUパワーも不足します。仮に全部ルートを乗せれたとしても、膨大な負荷がルータにかかってしまうことになります。

◆デフォルトルートの設定

デフォルトルートを指定するには、特別なネットワークアドレスと特別なサブネットマスクを使って設定します。

Router(config)#ip route 0.0.0.0 0.0.0.0 <ネクストホップ>

◆デフォルトルートを有効化する

Cisco IOS 11.3より古いIOSを使用している場合は、「ip classless」コマンドを実行します。

Router(config)#no ip classless


●Router_Aのコンフィグ
!
hostname Router_A
!
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 bandwidth 64
 ip address 172.16.2.1 255.255.255.0
 clock rate 64000
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.2.2 
!

●Router_Bのコンフィグ
!
hostname Router_B
!
interface Serial0/0/0
 bandwidth 64
 ip address 172.16.2.2 255.255.255.0
!
interface Serial0/0/1
 bandwidth 64
 ip address 172.16.3.1 255.255.255.0
 clock rate 64000
!
ip classless
ip route 172.16.1.0 255.255.255.0 172.16.2.1 
ip route 172.16.4.0 255.255.255.0 172.16.3.2 
!

●Router_Cのコンフィグ
!
hostname Router_C
!
interface FastEthernet0/0
 ip address 172.16.4.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 bandwidth 64
 ip address 172.16.3.2 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.3.1
!

PC_AからPC_Bにping してみます。pingは成功します。
◆Menu
◆スポンサードリンク
◆Amazon

Copyright(c)2014〜 Ciscoルータで学ぶネットワーク All rights reserved.