Ciscoルータで学ぶネットワーク > ルータの設定をコピーペーストで設定する
当サイト概要CCNA・CCENT・資格書籍学習環境の準備リンクについてリンクの申込お問い合せプライバシーポリシー
◆ルータの設定をコピーペーストで設定する

ルータの設定をコピーペーストで設定する


保存しておいた設定ファイルをルータに適応させるには、いくつか方法があります。

●ターミナルソフトの「ファイル」メニューを展開して設定ファイルを指定し転送する方法
●copy tftp running-config コマンドを使ってTFTPサーバ上の設定ファイルを指定する方法

などの方法がありますが、ここでは、もっと簡単な方法を紹介します。

設定を保存したテキストファイルを開きます。

※ここでは、保存した設定ファイルを設定して行きますが、「show running-config」コマンドで出力したルータのコンフィグを選択コピーしてテキストエディタで編集しても構いません。

 

インタフェースの設定のところで、「no shutdown」コマンドを追加しておきます。

 基本的に、設定ファイルを転送する際は、あらかじめルータの設定を空にしておきます。ルータの設定が空の場合、インタフェースはデフォルトで「shutdown」になっています。

 転送する設定ファイルに「no shutdown」コマンドを追加していない場合は、転送後、各インタフェースがdownしたままの状態になっています。

後から、各インタフェース設定モードに入って「no shutdown」コマンドを入力するのは面倒なので、「no shutdown」を入れておきます。

 

「no shutdown」コマンドを追加したら転送したい部分を選択して、「Ctrl + C」キーを押してクリップボードにコピーしておきます。


ルータにクリップボードにコピーした内容をルータに流し込みます。

ルータに設定を流し込むには、グローバル設定モードに移行しておく必要があります。

ここが、重要です。

 もし間違えて、違う設定モードでクリップボードの内容をルータに流し込むと、ルータがコマンドが解釈できなかったり、DNSにてコマンド名をホスト名として名前解決しようとして、しばらくの間、ルータは固まってしまいます。

ルータに設定を流し込む際は、必ずグローバル設定モードに移行しているかどうか確認してから行いましょう!

それでは、設定をルータに流し込んでみます。

グローバル設定モードで、

Router(config)#

のプロンプトのところで、「Ctrl + V」キーを押します。クリップボードにコピーしていた内容がルータ上で展開されます。

※マウスを右クリックしても同様なことができます。

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#! ← ここで、コピーペーストを行います
Router(config)#version 11.1
Router(config)#service udp-small-servers
Router(config)#service tcp-small-servers
Router(config)#!
Router(config)#hostname Router_A
Router_A(config)#!
Router_A(config)#enable password cisco
Router_A(config)#!
Router_A(config)#ip subnet-zero
Router_A(config)#!
Router_A(config)#interface Ethernet0
Router_A(config-if)# ip address 192.168.1.1 255.255.255.0
Router_A(config-if)# no shutdown
Router_A(config-if)#!
Router_A(config-if)#router ospf 1
Router_A(config-router)# network 192.168.1.0 0.0.0.255 area 0
Router_A(config-router)#!
Router_A(config-router)#ip classless
Router_A(config)#!
Router_A(config)#line con 0
Router_A(config-line)#line aux 0
Router_A(config-line)#line vty 0 4
Router_A(config-line)# password cisco
Router_A(config-line)# login
Router_A(config-line)#!
Router_A(config-line)#end
Router_A#

 このルータへの設定ファイルの流し込む方法を使えば、わざわざ各ルータで1つずつコマンドで設定しなくても済みます。テキストファイル上で設定内容を編集することで、ルータの設定時間を短縮できます。
◆Menu
◆スポンサードリンク
◆Amazon

Copyright(c)2014〜 Ciscoルータで学ぶネットワーク All rights reserved.