Ciscoルータで学ぶネットワーク > SDMのインストールと接続
当サイト概要CCNA・CCENT・資格書籍学習環境の準備リンクについてリンクの申込お問い合せプライバシーポリシー
◆SDMのインストールと接続

SDMのインストール


 2003年6月以降に製造され、VPNバンドルを搭載したルータには、あらかじめSDMがインストールされています。それ以外のルータには、別途、SDMをインストールする必要があります。

既にSDMがインストールされているルータには、ここで紹介する作業は、必要ありません。

ここでは、Cisco1710を使用してSDMのインストール方法を紹介して行きます。

◆flashの容量を確認する

SDMは、PCにインストールすることもルータにインストールすることもできます。

ルータに、SDMをインストールするには、flashに十分な空き容量がなければなりません。

そこで、ルータのflashの容量を調べます。

●「show flash」の出力
Router#show flash

System flash directory:
File  Length   Name/status
  1   12941880  c1710-k9o3sy-mz.124-17.bin
[12941944 bytes used, 3573124 available, 16515068 total]
16384K bytes of processor board System flash (Read/Write)

利用可能な残りのflashの容量を調べます。

利用可能なflashの容量が少ない場合、ルータにSDMをインストールすることができません。

 容量の小さいSDM Expressをインストールする手もありますが、SDM Expressは、SDMの簡易版で、本格的な設定を行うことができません。

上の例では、flashの空き容量が、不足しています。SDMをインストールするには、もっと空き容量が必要です。

そこで、PCにSDMをインストールすることにします。

◆ルータの初期設定

WebブラウザからのGUI操作を可能にするには、ルータの初期設定が必要です。

PCとルータとの接続は、下の図のようにします。


●IPアドレスを割り当てる

PCとルータが通信できるようにルータのF0インタフェースにIPアドレスを割り当てる必要があります。

Router(config)#interface f0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit

●HTTP/HTTPSサーバを有効にする

ルータのHTTP/HTTPSサーバ機能を有効にします。

Router(config)#ip http server
Router(config)#ip http secure-server
Router(config)#ip http authentication local

●特権レベル15で定義されたユーザアカウントを作成する

SDMでは、特権レベル15で定義されたユーザアカウントが要求されます。

 初回のSDMへの接続時に変更するように要求されますが、ここでは、ユーザ名「cisco」、パスワード「cisco」でユーザアカウントを作成しておきます。

Router(config)#username cisco privilege 15 password 0 cisco

 SDMでは、特権レベル15では、次のように、Telnet(0〜4)回線に対して、特権レベル15を割り当て、ローカルログイン、SSH/Telnetを設定する必要があります。

Router(config)#line vty 0 4
Router(config-line)#privilege level 15
Router(config-line)#login local
Router(config-line)#transport input telnet
Router(config-line)#exit

※SSHも設定する場合は、「transport input telnet」ではなく、「transport input telnet ssh」と指定します。ここでは、簡単にアクセスするためにtelnetだけを設定しています。

上で紹介した設定は、グローバル設定モードで以下のコンフィグを流し込むことでも設定できます。

interface f0
ip address 192.168.1.1 255.255.255.0
no shutdown
exit
ip http server
ip http secure-server
ip http authentication local
username cisco privilege 15 password 0 cisco
line vty 0 4
privilege level 15
login local
transport input telnet
exit

PCにSDMをインストールして行きます。

「setup.exe」をダブルクリックします。


「インストールウィザード」が起動します。

「次へ」をクリックします。



「使用許諾契約」が表示されます。

「同意する」にチェックを入れて、「次へ」をクリックします。


「インストールオプション」が表示されます。

「このコンピュータ」を選択して、「次へ」をクリックします。


「インストール先の選択」が表示されます。

インストール先のパスを選択して、「次へ」をクリックします。変更する必要がなければ、そのまま「次へ」をクリックします。


「インストール準備の完了」が表示されます。

「インストール」をクリックします。


インストールが開始されます。


しばらく待つとインストールが完了します。


デスクトップに次のアイコンができていることを確認します。


これで、インストールの完了です。


SDMへの接続


 SDMへはブラウザ経由でアクセスするようになります。Webブラウザのポップアップのブロック機能を解除しておきます。解除しておかないと、SDMを起動することができません。

「Cisco SDM」へのショートカットをダブルクリックして起動します。


「SDM Launcher」が起動します。

ルータに設定したIPアドレスを入力して、「起動する」をクリックします。


特権レベル15で定義されたユーザアカウントが要求されます。

ルータの初期設定で設定したユーザアカウント情報を入力します。

ユーザー名: cisco
パスワード: cisco

入力したら、「OK」ボタンをクリックします。


ブラウザが表示されます。


すると、再度、パスワードが要求されます。

ユーザー名: cisco
パスワード: cisco

入力したら、「はい」ボタンをクリックします。


「ステータス」画面が表示されます。

SDMがルータから現在の設定をロードするまでの間、しばらく待ちます。


デフォルトのユーザ名とパスワードを変更するようにと要求されます。

ここでは、以下のように入力しています。

ユーザー名: ccnaccnp
パスワード: ccnaccnp

入力したら、「OK」ボタンをクリックします。


「コマンド配信ステータス」が表示されます。

「OK」ボタンをクリックします。


「パスワードの要求」が表示されます。先ほど変更したユーザ名とパスワードを入力します。

ここでは、以下のように入力しています。

ユーザー名: ccnaccnp
パスワード: ccnaccnp

入力したら、「はい」ボタンをクリックします。


SDMが起動すれば、接続完了です。


 手順が長くなりましたが、そんなに難しい作業ではありません。表示されるウィザードに従って設定して行けば簡単にSDMに接続することができます。
◆Menu
◆スポンサードリンク
◆Amazon

Copyright(c)2014〜 Ciscoルータで学ぶネットワーク All rights reserved.