Ciscoルータで学ぶネットワーク > DNS(no ip domain-lookup)
当サイト概要CCNA・CCENT・資格書籍学習環境の準備リンクについてリンクの申込お問い合せプライバシーポリシー
◆DNS(no ip domain-lookup)

DNS(ip domain-lookup)


 Ciscoルータでは、 ホスト名とIPアドレスとの対応を「ip host」コマンドで定義することができます。しかし、この方法では、各ルータでホスト名とIPアドレスとの対応を「ip host」コマンドで定義する必要があり、規模の大きなネットワークでは、向いているとは言えません。

 ホスト名とIPアドレスを対応させる仕組みにDNS(Domain Naming System)がありますが、Ciscoルータでは、DNSサーバを使用して名前解決が行えるようになっています。

ここでは、CiscoルータのDNSサーバ機能を有効にする方法を紹介します。

使用するネットワークは、下図になります。


※ブロードバンドルータのDNSフォワード機能を有効にして、加入しているISPのDNSサーバのIPアドレスを設定しておきます。

まずは、Router_Aに基本的な設定を行います。

◆基本設定

Router#conf t
Router(config)#hostname Router_A
Router_A(config)#int f0
Router_A(config-if)#ip address 192.168.1.1 255.255.255.0
Router_A(config-if)#no shutdown
Router_A(config-if)#exit
Router_A(config)#line vty 0 4
Router_A(config-line)#password cisco
Router_A(config-line)#login
Router_A(config-line)#exit
Router_A(config)#enable password cisco

◆DNS機能を有効にする

ルータのDNS機能を有効にするには、グローバル設定モードで、「ip domain-lookup」コマンドを使用します。

ちなみに、このコマンドを設定しなくともデフォルトでDNS機能を有効になっています。

Router_A(config)#ip domain-lookup

ちなみに「show run」コマンドで確認すると「ip domain-lookup」コマンドがないことが確認できます。

!
hostname Router_A
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
interface FastEthernet0
 ip address 192.168.1.1 255.255.255.0
 speed auto
!
line vty 0 4
 password cisco
 login
!
end

◆デフォルトルートを追加する

Router_Aにデフォルトルートを追加します。

Router_A(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.254

これで、設定は全て完了です。

Router_Aのコンソールからpingコマンドを実行します。

Router_A#ping www.yahoo.co.jp

●Router_Aの「ping」の出力
Router_A#ping www.yahoo.co.jp

Translating "www.yahoo.co.jp"...domain server (255.255.255.255) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 124.83.139.192, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms

「www.yahoo.co.jp」が名前解決され、pingが成功します。

DNSサーバのIPアドレスを指定しなくとも、Router_Aと同じセグメントにDNSサーバが存在すれば、名前解決は成功します。


DNS(no ip domain-lookup)


 ホスト名とIPアドレスを対応させる仕組みにDNS(Domain Naming System)がありますが、Ciscoルータでは、DNSサーバを使用して名前解決が行えるようになっています。

 このDNS機能は、デフォルトで有効になっており、認識できない文字列を入力してしまった場合、ネットワーク上のDNSサーバに「255.255.255.255」のブロードキャストで問い合わせを行うため、しばらくの間、コマンドの入力を受け付けない状態が続きます。

 DNS機能を無効にすれば、コマンドのタイプミスをしても、すぐに入力することができるので、無駄な時間を減らすことができます。特に、Ciscoルータのコマンド操作を学習中においては、頻繁に間違えてコマンドを入力してしまうため、有効だと思います。

ここでは、CiscoルータのDNSサーバ機能を無効にする方法を紹介します。

使用するネットワークは、下図になります。

※ブロードバンドルータのDNSフォワード機能を有効にして、加入しているISPのDNSサーバのIPアドレスを設定しておきます。

まずは、Router_Aに基本的な設定を行います。

◆基本設定

Router#conf t
Router(config)#hostname Router_A
Router_A(config)#int f0
Router_A(config-if)#ip address 192.168.1.1 255.255.255.0
Router_A(config-if)#no shutdown
Router_A(config-if)#exit
Router_A(config)#line vty 0 4
Router_A(config-line)#password cisco
Router_A(config-line)#login
Router_A(config-line)#exit
Router_A(config)#enable password cisco

◆DNS機能を無効にする

ルータのDNS機能を無効にするには、グローバル設定モードで、「no ip domain-lookup」コマンドを使用します。

Router_A(config)#no ip domain-lookup

「show run」コマンドで確認すると「no ip domain-lookup」コマンドがあることが確認できます。

!
hostname Router_A
!
enable password cisco
!
no aaa new-model
memory-size iomem 25
!
no ip domain lookup
!
interface FastEthernet0
 ip address 192.168.1.1 255.255.255.0
 speed auto
!
line vty 0 4
 password cisco
 login
!
end

これで、設定はすべて完了です。

Router_Aのコンソールで、わざとコマンドのタイプミスをしてみます。

「ping」コマンドではなく、「pong」と間違えてみます。

Router_A#pong

●Router_Aの出力
Router_A#pong
Translating "pong"

Translating "pong"
% Unknown command or computer name, or unable to find computer address

「pong」の名前解決が中止され、コマンドが無効であるメッセージが表示されます。
◆Menu
◆スポンサードリンク
◆Amazon

Copyright(c)2014〜 Ciscoルータで学ぶネットワーク All rights reserved.