Ciscoルータで学ぶネットワーク > DNSサーバの指定(ip name-server)
当サイト概要CCNA・CCENT・資格書籍学習環境の準備リンクについてリンクの申込お問い合せプライバシーポリシー
◆DNSサーバの指定(ip name-server)

DNSサーバの指定(ip name-server)


 Ciscoルータでは、 ホスト名とIPアドレスとの対応を「ip host」コマンドで定義することができます。しかし、この方法では、各ルータでホスト名とIPアドレスとの対応を「ip host」コマンドで定義する必要があり、規模の大きなネットワークでは、向いているとは言えません。

 ホスト名とIPアドレスを対応させる仕組みにDNS(Domain Naming System)がありますが、Ciscoルータでは、DNSサーバを使用して名前解決が行えるようになっています。

 ルータのDNS機能を有効にするには、グローバル設定モードで、「ip domain-lookup」コマンドを使用します。このコマンドは設定を行わなくともデフォルトでDNS機能を有効になっており、設定する必要はありません。

つまり、CiscoルータはデフォルトでDNSサーバを用いて名前解決を行うようになっています。

 しかし、デフォルトのままでは、ルータは、「255.255.255.255」のブロードキャストを用いてDNSサーバに問い合わせをするため、同じセグメント上にDNSサーバが存在していなければなりません。

異なるセグメント上のDNSサーバを使用する場合には、「ip name-server」コマンドを使用します。

ここでは、「ip name-server」コマンドしようしてDNSサーバを指定する方法を紹介して行きます。

使用するネットワークは、下図になります。


※このネットワーク構成では、「ip name-server」コマンドを使用しなくとも名前解決が行えます。
※ブロードバンドルータのDNSフォワード機能を有効にして、加入しているISPのDNSサーバのIPアドレスを設定しておきます。

まずは、Router_Aに基本的な設定を行います。

◆基本設定

Router#conf t
Router(config)#hostname Router_A
Router_A(config)#int f0
Router_A(config-if)#ip address 192.168.1.1 255.255.255.0
Router_A(config-if)#no shutdown
Router_A(config-if)#exit
Router_A(config)#line vty 0 4
Router_A(config-line)#password cisco
Router_A(config-line)#login
Router_A(config-line)#exit
Router_A(config)#enable password cisco

◆DNSサーバを指定する

ルータのDNS機能を有効にするには、グローバル設定モードで、「ip domain-lookup」コマンドを使用します。

ちなみに、このコマンドを設定しなくともデフォルトでDNS機能を有効になっています。

Router_A(config)#ip domain-lookup

「ip name-server」コマンドで、DNSサーバを指定します。

Router_A(config)#ip name-server 192.168.1.254

◆デフォルトルートを追加する

Router_Aにデフォルトルートを追加します。

Router_A(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.254

これで、設定は全て完了です。


Router_Aのコンソールからpingコマンドを実行します。

Router_A#ping www.yahoo.co.jp

●Router_Aの「ping」の出力
Router_A#ping www.yahoo.co.jp

Translating "www.yahoo.co.jp"...domain server (192.168.1.254) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 203.216.247.249, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/21/24 ms

「www.yahoo.co.jp」が名前解決され、pingが成功します。

続いて、

Router_A#ping www.goo.ne.jp

●Router_Aの「ping」の出力
Router_A#ping www.goo.ne.jp

Translating "www.goo.ne.jp"...domain server (192.168.1.254) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 210.165.9.195, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/22/24 ms
Router_A#

「www.goo.ne.jp」が名前解決され、pingが成功します。

●Router_Aの設定
!
hostname Router_A
!
enable password cisco
!
ip name-server 192.168.1.254
!
interface FastEthernet0
 ip address 192.168.1.1 255.255.255.0
 speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.1.254
!
line vty 0 4
 password cisco
 login
!
end

DNS機能を無効にすれば、コマンドのタイプミスをしても、すぐに入力することができるので、無駄な時間を減らすことができます。
◆Menu
◆スポンサードリンク
◆Amazon

Copyright(c)2014〜 Ciscoルータで学ぶネットワーク All rights reserved.